<!doctype html>
<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->
<head>
<meta charset="utf-8">
<script>
  (function(d) {
    var config = {
      kitId: 'sbr1hog',
      scriptTimeout: 3000,
      async: false
    },
    h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='https://use.typekit.net/'+config.kitId+'.js';tk.async=false;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)
  })(document);
</script>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<title>Trinity Meteors Win Division 1 Player and Coach of the Year &ndash; The University Times</title>
<meta name="HandheldFriendly" content="True">
<meta name="MobileOptimized" content="320">
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />

<meta property="og:title" content="Trinity Meteors Win Division 1 Player and Coach of the Year" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@universitytimes">
<meta name="twitter:title" content="Trinity Meteors Win Division 1 Player and Coach of the Year">
<meta name="twitter:description" content="Edel Thornton and Vinnie O'Keefe were both recognised after a hugely successful season for Meteors.">
<meta name="twitter:image" content="http://www.universitytimes.ie/wp-content/uploads/2020/04/meteors-e1583698352807.jpg">
<meta property="og:image" content="http://www.universitytimes.ie/wp-content/uploads/2020/04/meteors-e1583698352807.jpg" />
<meta property="og:description" content="Edel Thornton and Vinnie O'Keefe were both recognised after a hugely successful season for Meteors." />
<!--[if IE]>
			<link rel="shortcut icon" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/favicon.ico">
		<![endif]-->
<link rel="apple-touch-icon" sizes="57x57" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/favicon-16x16.png">
<link rel="manifest" href="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/favicons/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">
<link rel="pingback" href="http://www.universitytimes.ie/xmlrpc.php">
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The University Times &raquo; Feed" href="http://www.universitytimes.ie/feed/" />
<link rel="alternate" type="application/rss+xml" title="The University Times &raquo; Comments Feed" href="http://www.universitytimes.ie/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The University Times &raquo; Trinity Meteors Win Division 1 Player and Coach of the Year Comments Feed" href="http://www.universitytimes.ie/2020/04/trinity-meteors-win-division-1-player-and-coach-of-the-year/feed/" />




<script type="text/javascript">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</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='http://www.universitytimes.ie/wp-includes/css/dist/block-library/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='bones-stylesheet-css' href='http://www.universitytimes.ie/wp-content/themes/universitytimes/library/css/style.css?nnewonen220' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='http://www.universitytimes.ie/wp-content/themes/universitytimes/library/css/ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='googleFonts-css' href="https://fonts.googleapis.com/css?family=Lato%3A400%2C700%2C400italic%2C700italic" type='text/css' media='all' />
<script type='text/javascript' src='http://www.universitytimes.ie/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.universitytimes.ie/wp-includes/js/jquery/jquery-migrate.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"http:\/\/www.universitytimes.ie\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.universitytimes.ie/wp-content/themes/universitytimes/library/js/customajax.js'></script>
<script type='text/javascript' src='http://www.universitytimes.ie/wp-content/themes/universitytimes/library/js/libs/modernizr.custom.min.js'></script>
<link rel='https://api.w.org/' href='http://www.universitytimes.ie/wp-json/' />
<link rel="canonical" href="http://www.universitytimes.ie/2020/04/trinity-meteors-win-division-1-player-and-coach-of-the-year/" />
<link rel='shortlink' href='http://www.universitytimes.ie/?p=89082' />
<link rel="alternate" type="application/json+oembed" href="http://www.universitytimes.ie/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.universitytimes.ie%2F2020%2F04%2Ftrinity-meteors-win-division-1-player-and-coach-of-the-year%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.universitytimes.ie/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.universitytimes.ie%2F2020%2F04%2Ftrinity-meteors-win-division-1-player-and-coach-of-the-year%2F&#038;format=xml" />
<link rel="stylesheet" href="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.0/themes/smoothness/jquery-ui.css" />
<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.0/jquery-ui.min.js"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/d3/3.4.11/d3.js"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/ember.js/1.6.1/ember.min.js"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/jquery.imagesloaded/2.1.0/jquery.imagesloaded.min.js"></script>
<script src="http://www.universitytimes.ie/wp-content/themes/universitytimes/javascript/jquery-imagefill.js"></script>
<script src="http://www.universitytimes.ie/wp-content/themes/universitytimes/javascript/jquery.waypoints.js"></script>
<script src="https://ajax.aspnetcdn.com/ajax/jquery.validate/1.14.0/jquery.validate.min.js"></script>
<script src="http://www.universitytimes.ie/wp-content/themes/universitytimes/javascript/shortcuts/sticky.min.js"></script>
<script src="http://www.universitytimes.ie/wp-content/themes/universitytimes/javascript/readmore.min.js"></script>
<script src="http://www.universitytimes.ie/wp-content/themes/universitytimes/library/js/customajax.js"></script>
<script src="http://www.universitytimes.ie/wp-content/themes/universitytimes/javascript/jquery.dotdotdot.min.js"></script>
<link href="//fonts.googleapis.com/css?family=PT+Serif:400italic,400,700italic,700" rel="stylesheet" type="text/css">
<link href="https://fonts.googleapis.com/css?family=Alfa+Slab+One" rel='stylesheet' type='text/css'>
<link href='https://fonts.googleapis.com/css?family=Martel:900' rel='stylesheet' type='text/css'>
</head>
<body class="post-template-default single single-post postid-89082 single-format-standard">
<div id="container">
<div class="headercontained">
<header class="header" role="banner">
<script>
					
					jQuery(document).ready(function(){
     
     
     
     jQuery(".newsfeedlink").mouseover(function(){
         jQuery("#logo").removeClass("whiteshadow");
         
         
         
         
         
         
      
     });
     
     
     jQuery(".newsfeedlink").mouseout(function(){
         
         
      setTimeout(function(){   jQuery("#logo").addClass("whiteshadow"); }, 100);
         
         
         
         
         
         
      
     });
     
     
     
     
     
     
     
     
     
     
     
     
});
					
					</script>
<h1 id="logo" class="whiteshadow"><a href="http://www.universitytimes.ie" rel="nofollow">The University Times</a></h1>
<div class="heightstop">
<div class="navigationtopcontainer">
<nav class="toplevel">
<div class="greatboom">
<script>
				
			jQuery(function ($) {
			
			
			$.fn.slideFadeToggle  = function(speed, easing, callback) {
        return this.animate({opacity: 'toggle', height: 'toggle'}, speed, easing, callback);
};
			
	
			
			$(".goddess").click(function() {
   $('#boom').slideFadeToggle();
});	







 








 $(window).resize(function() {
  if ($(window).width() > 710) {
  
  
  
   $('#boom').fadeIn();
    
    
    
  }


});


$(window).resize(function() {
  if ($(window).width() < 711) {
  
  
  
   $('#boom').hide();
    
    
    
  }


});



 




 $(window).resize(function() {
  if ($(window).width() > 972) {
  
  
  
   $('.hider').fadeIn();
    
    
    
  }


});

$(window).resize(function() {
  if ($(window).width() < 973) {
  
  
  
   $('.hider').hide();
    
    
    
  }


});













				
				
				});
				</script>
<label for="show-menu" class="show-menu goddess">All Sections</label>
<input type="checkbox" id="show-menu" role="button" />
<ul id="boom">
<li>
<a href="http://www.universitytimes.ie/news" class="newsfeedlink">News <span style="font-size: 9px;" class="oi" data-glyph="caret-bottom" title="caret bottom" aria-hidden="true">
</span>
</a>
<ul class="boomsub">
<h4 class="miniheading">The Latest</h4>
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/likelihood-grows-of-delay-to-leaving-certificate-exams/" title="Likelihood Grows of Delay to Leaving Certificate Exams">Likelihood Grows of Delay to Leaving Certificate Exams</a></li>
<hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/trinity-to-set-up-coronavirus-research-centre-with-e2-4m-aib-backing/" title="Trinity to Set Up Coronavirus Research Centre, With €2.4m AIB Backing">Trinity to Set Up Coronavirus Research Centre, With €2.4m AIB Backing</a></li>
<hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/trinity-will-use-turnitin-to-combat-cheating-in-real-time-exams/" title="Trinity Will Use Turnitin to Combat Cheating in Real-Time Exams">Trinity Will Use Turnitin to Combat Cheating in Real-Time Exams</a></li>
<li class="seemore"><a class="moremore" href="http://www.universitytimes.ie/news">SEE ALL NEWS</a></li>
</ul>
</li>
<li><a href="http://www.universitytimes.ie/infocus" class="infocuslink">In Focus <span style="font-size: 9px;" class="oi" data-glyph="caret-bottom" title="caret bottom" aria-hidden="true"></span></a>
<ul class="boomsubfeature clearfix">
<li class="listone">
<ul class="listoneul clearfix">
<li class="leftone"><a class="" href="http://www.universitytimes.ie/2020/04/when-it-comes-to-climate-academics-say-we-really-are-what-we-eat/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper1').imagefill();
        						</script>
<span>When it Comes to Climate, Academics Say We Really Are What We Eat</span></li>
<li class="rightone"><a class="" href="http://www.universitytimes.ie/2020/04/in-1904-the-steamboat-ladies-kicked-off-a-trinity-equality-battle-its-still-going/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper2').imagefill();
        						</script>
<span>In 1904, the ‘Steamboat Ladies’ Kicked Off a Trinity Equality Battle. It’s Still Going</span></a></li>
</ul> 
</li> 
<li class="listtwo">
<ul class="listtwoul clearfix">
<li class="lefttwo">
<ul class="lefttwoul">
<h4 class="miniheading">More Stories</h4>
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/the-trinity-graduate-helping-in-a-450km-run-for-hospitals/">The Trinity Graduate Helping in a 450km Run for Hospitals</a></li>
<hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/on-the-frontlines-and-behind-the-scenes-students-help-fight-the-virus/" title="On the Frontlines and Behind the Scenes, Students Help Fight the Virus">On the Frontlines and Behind the Scenes, Students Help Fight the Virus</a></li><hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/how-us-politics-is-getting-down-with-the-kids/" title="How US Politics Is Getting Down With the Kids">How US Politics Is Getting Down With the Kids</a></li>
<li class="seemore"><a class="moremore" href="http://www.universitytimes.ie/infocus">SEE ALL IN FOCUS</a></li>
</ul>
</li>
<li class="righttwo">
<ul class="righttwoul">
<h4 class="miniheading">More from In Focus</h4>
<li><a href="http://www.universitytimes.ie/interviews">Interviews</a></li>
</ul>
</li>
</ul>
</li>
<div style="clear: both;"></div>
</ul>
</li>
<li><a href="http://www.universitytimes.ie/opinion" class="opinionlink">Opinion <span style="font-size: 9px;" class="oi" data-glyph="caret-bottom" title="caret bottom" aria-hidden="true"></span></a>
<ul class="boomsubopinion clearfix">
<li class="listone">
<ul class="listoneul clearfix">
<li class="leftone"><a class="" href="http://www.universitytimes.ie/2020/04/college-has-said-no-to-no-detriment-but-obeyed-the-spirit-of-the-policy/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper3').imagefill();
        						</script>
<span>College Has Said No to No Detriment – But Obeyed the Spirit of the Policy</span></li>
<li class="rightone"><a class="" href="http://www.universitytimes.ie/2020/04/ni-bheadh-polasai-gan-diobhail-foirfe-ach-is-e-an-moladh-is-fearr-ata-cloistithe-againn/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper4').imagefill();
        						</script>
<span>Ní Bheadh Polasaí Gan Díobháil Foirfe – Ach Is É An Moladh Is Fearr Atá Cloistithe Againn</span></a></li>
</ul> 
</li> 
<li class="listtwo">
<ul class="listtwoul clearfix">
<li class="lefttwo">
<ul class="lefttwoul">
<h4 class="miniheading">More Opinions</h4>
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/no-detriment-isnt-a-perfect-policy-but-its-the-best-proposal-weve-seen/">No Detriment Isn’t a Perfect Policy – But It’s the Best Proposal We’ve Seen</a></li>
<hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/03/comhartha-iad-na-liomhainti-i-leith-an-hist-go-bhfuil-an-t-eiliteachas-sa-cholaiste/" title="Comhartha Iad na Líomhaintí i Leith an Hist go Bhfuil an t-Éilíteachas sa Choláiste">Comhartha Iad na Líomhaintí i Leith an Hist go Bhfuil an t-Éilíteachas sa Choláiste</a></li><hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/03/hist-accusations-a-timely-reminder-again-that-elitism-has-deep-roots-in-trinity/" title="Hist Accusations a Timely Reminder – Again – That Elitism Has Deep Roots in Trinity">Hist Accusations a Timely Reminder – Again – That Elitism Has Deep Roots in Trinity</a></li>
<li class="seemore"><a class="moremore" href="http://www.universitytimes.ie/opinion">SEE ALL IN OPINION</a></li>
</ul>
</li>
<li class="righttwo">
<ul class="righttwoulopinion">
<h4 class="miniheading">More from Opinion</h4>
<li><a href="http://www.universitytimes.ie/columns">Columns</a></li>
<li><a href="http://www.universitytimes.ie/editorials">Editorials</a></li>
<li><a href="http://www.universitytimes.ie/profile/">Profiles</a></li>
<li><a href="http://www.universitytimes.ie/op-ed/">Op-Eds</a></li>
<li><a href="http://www.universitytimes.ie/loveinterest">Love Interest</a></li>
</ul>
</li>
</ul>
</li>
<div style="clear: both;"></div>
</ul>
</li>
<li><a href="http://www.universitytimes.ie/sport" class="sportlink">Sport <span style="font-size: 9px;" class="oi" data-glyph="caret-bottom" title="caret bottom" aria-hidden="true"></span></a>
<ul class="boomsubopinion clearfix sport">
<li class="listone">
<ul class="listoneul clearfix">
<li class="leftone"><a class="" href="http://www.universitytimes.ie/2020/04/trinity-meteors-win-division-1-player-and-coach-of-the-year/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper5').imagefill();
        						</script>
<span>Trinity Meteors Win Division 1 Player and Coach of the Year</span></li>
<li class="rightone"><a class="" href="http://www.universitytimes.ie/2020/04/college-classics-australias-cricketers-come-to-town-and-defeat-trinity/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper6').imagefill();
        						</script>
<span>College Classics: Australia’s Cricketers Come to Town – and Defeat Trinity</span></a></li>
</ul> 
</li> 
<li class="listtwo">
<ul class="listtwoul clearfix">
<li class="lefttwo">
<ul class="lefttwoul">
<h4 class="miniheading">More Sport</h4>
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/for-lauren-grigsby-meteors-shooting-star-losing-was-not-an-option/">For Lauren Grigsby, Meteors’ Shooting Star, &#8216;Losing Was Not an Option’</a></li>
<hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/college-classics-a-famous-day-for-trinity-rugby-with-ail-promotion/" title="College Classics: A Famous Day for Trinity Rugby, With AIL Promotion">College Classics: A Famous Day for Trinity Rugby, With AIL Promotion</a></li><hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/03/duafcs-dylan-connolly-has-his-sights-trained-on-the-top/" title="DUAFC&#8217;s Dylan Connolly Has His Sights Trained on the Top">DUAFC&#8217;s Dylan Connolly Has His Sights Trained on the Top</a></li>
<li class="seemore"><a class="moremore" href="http://www.universitytimes.ie/sport">SEE ALL IN SPORT</a></li>
</ul>
</li>
<li class="righttwo">
<ul class="righttwoulopinion">
<h4 class="miniheading">More from Sport</h4>
<li><a href="">Rugby</a></li>
<li><a href="">Soccer</a></li>
<li><a href="">Rowing</a></li>
<li><a href="">Fencing</a></li>
</ul>
</li>
</ul>
</li>
<div style="clear: both;"></div>
</ul>
</li>
<li><a href="http://www.universitytimes.ie/magazine" class="magazinelink">Magazine <span style="font-size: 9px;" class="oi" data-glyph="caret-bottom" title="caret bottom" aria-hidden="true"></span></a>
<ul class="boomsubopinion clearfix sport">
<li class="listone">
<ul class="listoneul clearfix">
<li class="leftone"><a class="" href="http://www.universitytimes.ie/2020/04/a-new-political-geography/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper7').imagefill();
        						</script>
<span>A New Political Geography?</span></li>
<li class="rightone"><a class="" href="http://www.universitytimes.ie/2020/04/pandemic-at-the-disco-dj-culture-is-spreading-like-a-virus-we-must-resist/"><h4 class="miniheading"></h4>

<script type="text/javascript">
											jQuery('.cropper8').imagefill();
        						</script>
<span>Pandemic at the Disco: DJ Culture is Spreading Like a Virus. We Must Resist</span></a></li>
</ul> 
</li> 
<li class="listtwo">
<ul class="listtwoul clearfix">
<li class="lefttwo">
<ul class="lefttwoul">
<h4 class="miniheading">More Magazine</h4>
<div style="display:none"><a href="http://rusbankinfo.ru">займ на карту</a></div>
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/04/yellow-vests-and-unrest-in-the-home-of-protest/">Yellow Vests and Unrest in the Home of Protest</a></li>
<hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/03/the-dublin-activists-making-the-environment-a-feminist-issue/" title="The Dublin Activists Making the Environment a Feminist Issue">The Dublin Activists Making the Environment a Feminist Issue</a></li><hr />
<li><a class="boomsublink" href="http://www.universitytimes.ie/2020/03/catherine-corless-unearthing-one-of-the-churchs-darkest-secrets/" title="Catherine Corless: Unearthing One of the Church&#8217;s Darkest Secrets">Catherine Corless: Unearthing One of the Church&#8217;s Darkest Secrets</a></li>
<li class="seemore"><a class="moremore" href="http://www.universitytimes.ie/magazine">SEE ALL IN MAG</a></li>
</ul>
</li>
<li class="righttwo">
<ul class="righttwoulopinion">
<h4 class="miniheading">More from Mag</h4>
<li><a href="http://www.universitytimes.ie/category/fashion">Fashion</a></li>
<li><a href="http://www.universitytimes.ie/category/music">Music</a></li>
</ul>
</li>
</ul>
</li>
<div style="clear: both;"></div>
</ul>
</li>
<li><a href="http://www.universitytimes.ie/radius" class="radiuslink">Radius <span style="font-size: 9px;" class="oi" data-glyph="caret-bottom" title="caret bottom" aria-hidden="true"></span></a></li>

</ul>
</div> 
<script>
					
					jQuery(function ($) {
					
					
					
					
					$(".allsect").click(function(){
  $(".allsect").toggleClass("activity");
  
  $(".allsectionsbox").scrollTop( 0 );
  
  $(".allsectionsbox").toggle(200);
  
  
});
					
					
						
					
					
					
					});
					
					
					
					
					</script>
<div class="sectionboxstuff">
<div class="allsect">
<a class="cheeseit" id="hamburger-icon" href="#" title="Menu">
<span class="line-1"></span>
<span class="line-2"></span>
<span class="line-3"></span>
</a>
<span class="alltext">ALL</span> <span class="sectiontext">SECTIONS</span>
</div>
<div class="allsectionsbox">
<div class="allsectionsscroller">
<ul>
<li><a href="http://www.universitytimes.ie/news">News</a></li>
<li><a href="http://www.universitytimes.ie/infocus">In Focus</a></li>
<li><a href="http://www.universitytimes.ie/opinion">Comment & Analysis</a>
<ul>
<li><a href="http://www.universitytimes.ie/editorials/">Editorials</a></li>
<li><a href="http://www.universitytimes.ie/columns/">Columns</a></li>
<li><a href="http://www.universitytimes.ie/op-ed/">Op-Eds</a></li>
<li><a href="http://www.universitytimes.ie/opinioncontrib/">Contributions</a></li>
<li><a href="http://www.universitytimes.ie/profile/">Profiles</a></li>
<li><a href="http://www.universitytimes.ie/loveinterest/">Love Interest</a></li>
</ul>
</li>

<li><a href="http://www.universitytimes.ie/sport">Sport</a>

</li>
<li><a href="http://www.universitytimes.ie/radius">Radius</a></li>
<li><a href="http://www.universitytimes.ie/magazine">Magazine</a></li>


</ul>
</div>
<div class="allsectionsbox-fader"></div>
</div>
</div>
<div class="shilly">
<div class="pusherit">
<div class="hider">
<div class="searchboxd">
<form class="searchformform" style="" method="get" id="searchform" action="http://www.universitytimes.ie/">
<div><input type="text" name="s" id="s" value="Search" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" />
<button type="submit" id="searchsubmit" value="Search" class="btn"><span style="" class="oi searchicon" data-glyph="magnifying-glass" title="magnifying glass" aria-hidden="true"></span> </button>
</div>
</form>
</div> 
</div> 
<div class="searchpush">
<div id="excontainer">
<a id="ex-icon" class="cheeseit2" href="#" title="Menu">
<span class="line ex-1"></span>
<span class="line ex-2"></span>
</a>
</div>
<div id="searchitcontainer">
<span style="" class="oi searchicon" data-glyph="magnifying-glass" title="magnifying glass" aria-hidden="true"></span>
</div>
</div>
<div style="clear: both;"></div>
</div> 
<script>
					
					jQuery(function ($) {
					
					
				$(".searchpush").click(function () {

    // Set the effect type
    var effect = 'slide';

    // Set the options for the effect type chosen
    var options = { direction: 'right' };

    // Set the duration (default: 400 milliseconds)
    var duration = 400;
    
    var delay = 410;
    
    

    $('.hider').toggle(effect, options, duration, callbackFn);
    
     
     function callbackFn(){

     

     $('.hider').is(":visible") ?  $('#s').focus() :  $('#s').focusout();


} 
     
     
     
     
     
     		
});		




$( "#s" ).focus(function() {
  

		
		
		$( "#searchitcontainer" ).delay( 100 ).fadeOut(100);

		$( "#excontainer" ).delay( 100 ).fadeIn(220);



		
		 	
		 	
	
	
	
	
	
	
	
	
	
		 
			
  
});


$( "#s" ).focusout(function() {
  

		
		
		$( "#searchitcontainer" ).delay( 300 ).fadeIn(320);

		$( "#excontainer" ).delay( 300 ).fadeOut(200);



		
		 	
	
	
	
	
	
	
	
	
	
		 
			
  
});







	
 
  
   






$(document).mouseup(function (e)
{
    var container = $(".shilly");

    if (!container.is(e.target) // if the target of the click isn't the container...
        && container.has(e.target).length === 0) // ... nor a descendant of the container
    {
         if ($(window).width() < 981) {
         
         if ($(this).find('.hider').is(':visible')) {
   
      // Set the effect type
    var effect = 'slide';

    // Set the options for the effect type chosen
    var options = { direction: 'right' };

    // Set the duration (default: 400 milliseconds)
    var duration = 400;
  
  
  
	$('.hider').toggle(effect, options, duration);
	
	}
	
	}

    }
});			



    
    
 


					
					
					
					});
					
					
					
					
					</script>
</div> 
</nav>
</div> 
</div>
</header>
</div> 
<div id="content">
<div id="articlecontent">
<header class="article-header">
<div class="infogrouping">
<a href="http://www.universitytimes.ie/sport" class="articlesectiontag sporttag">Sport</a>
<div class="dateright">Apr 9, 2020</div>
<div style="clear: both;"></div>
</div>
<h2 class="articleheadline" itemprop="headline">Trinity Meteors Win Division 1 Player and Coach of the Year</h1>
<h3 class="articlesub">Edel Thornton and Vinnie O'Keefe were both recognised after a hugely successful season for Meteors.</h3>
</header>

<div style="clear:both"> </div>
<div class="utcontentgrouping utcontentgroupinglandscape">
<div class="writershareblock">
<span class="onebigauthorname">
<span class="authoruppercase">
Matt McCann
</span> and
<span class="authoruppercase">
Fiachra Gallagher
</span>
</span>
<script>
														 
														jQuery(document).ready(function($) {
							jQuery('a.popup').live('click', function(){
								newwindow=window.open($(this).attr('href'),'','height=420,width=500');
								if (window.focus) {newwindow.focus()}
								return false;
							});
							
							
			jQuery(function($) {

	jQuery('.sharebuttonsblock').waypoint(function(direction) {
		if (direction == 'up') {
			
			
			if ( jQuery(".sharebuttonsblock").parent().is( ".stuck" ) ) {
 			
			jQuery( ".sharebuttonsblock" ).unwrap(); }
			
			jQuery( ".stuck" ).hide();
		}
		else {
			jQuery( ".sharebuttonsblock" ).wrap( "<div class='stuck'></div>" );
			
			jQuery( ".stuck" ).fadeIn( 300 );
			
		}
	},
	{
		offset: '0%',
	});
	
	
	if ($(window).width() < 584) {
		
		
		
		
		

  var ref1 = document.referrer;
 

var facebook = "facebook";
var twitter = "twitter";
var tco = "t.co";

if (ref1.indexOf(facebook) > -1 || ref1.indexOf(twitter) > -1 || ref1.indexOf(tco) > -1 ) {
	
	
	jQuery('.utpost-content').readmore({
  speed: 75,
  moreLink: '<div class="readmoremobile"><a href="#">Read full article</a></div>',
  lessLink: '',
  collapsedHeight: 375,
  embedCSS: false,
  heightMargin: 100,
  
});
	
	
	}
    
else { }
	
	
	


}
	
	
	

});

	
							
						}); 
						
						
						
						jQuery(window).resize(function() {
console.log(jQuery(window).width());
if (jQuery(window).width() > 1) {
    jQuery('.utpost-content').readmore('destroy');
    
}
else
{
     }
});
jQuery(window).trigger('resize');
						
						
														 
														 
														 </script>

<script>
												
												
												  
												  
  
 
 
  
												 
												 
												 											
												
												</script>
<div class="sharebuttonsblock								
							
							">
<a href="https://www.facebook.com/sharer/sharer.php?u=http://www.universitytimes.ie/2020/04/trinity-meteors-win-division-1-player-and-coach-of-the-year/" class="facebookshare popup"></a>
<a href="https://twitter.com/home?status=Trinity%20Meteors%20Win%20Division%201%20Player%20and%20Coach%20of%20the%20Year%20http://www.universitytimes.ie/2020/04/trinity-meteors-win-division-1-player-and-coach-of-the-year/%20via%20%40universitytimes" class="twittershare popup"></a>
<a href="/cdn-cgi/l/email-protection#1a25696f78707f796e274e727f3a4f74736c7f6869736e633a4e73777f693a3c747e7b6972213a4e687374736e633a577f6e7f7568693a4d73743a5e736c73697375743a2b3a4a767b637f683a7b747e3a59757b79723a757c3a6e727f3a437f7b683c7b776a2178757e63275f7e7f763a4e727568746e75743a7b747e3a4c737474737f3a553d517f7f7c7f3a6d7f687f3a78756e723a687f79757d7473697f7e3a7b7c6e7f683a7b3a726f7d7f76633a696f79797f69697c6f763a697f7b6975743a7c75683a577f6e7f756869343f2a5e3f2a5b3f2a5e3f2a5b726e6e6a2035356d6d6d346f74736c7f6869736e636e73777f6934737f35282a282a352a2e356e687374736e6337777f6e7f756869376d7374377e736c7369737574372b376a767b637f68377b747e3779757b797237757c376e727f37637f7b68353f2a5e3f2a5b3f2a5e3f2a5b3f2a5e3f2a5b3f2a5e3f2a5b" class="emailshare"></a>
</div>
<div style="clear: both"></div>
</div>
<div class="imageadgroup landscaperight">
<div class="articleimage">
<img class="landscapeabove" src="http://www.universitytimes.ie/wp-content/uploads/2020/04/meteors-e1583698352807.jpg" alt="blank" />
<div class="oneimageactualcaption">Meteors were crowned Division 1 league champions last month, securing promotion to Ireland's Super League.
<div class="oneimagecaption"></div>
</div>
</div>
<div class="articlead">
<a href="https://www.tcd.ie/tangent/accelerators/launchbox/apply/">
<img src="http://universitytimes.ie/wp-content/themes/universitytimes/library/images/rsz_finalut_onlinead.png" />
</a>
</div>
<div style="clear:both"> </div>
</div>
<section class="utpost-content cf" itemprop="articleBody">
<p>Edel Thornton and Vinnie O’Keefe, of Trinity Meteors, have won player and coach of the season respectively in Division 1 of the Irish Basketball League. </p>
<p>Thornton won the Player of the Year award in the Women’s Division 1, while Meteors head coach Vinnie O’Keefe was named Coach of the Year in the same category.</p>
<p>Thornton, a key performer on the court for Meteors this season, also picked up a separate college-level award, after being named NBCC College Division 1 Player of the Year for her displays in the intervarsity competition.</p><div class="mobilearticlead">ADVERTISEMENT<a href="https://www.tcd.ie/tangent/accelerators/launchbox/apply/">
<img src="http://universitytimes.ie/wp-content/themes/universitytimes/library/images/rsz_finalut_onlinead.png" />
</a></div>
<p>Thornton won a number of Player of the Month accolades over the course of this season. O’Keefe was also recognised on several occasions at the monthly awards.</p>
<p>Edel Thornton joined Trinity Meteors this season as a sports scholar. She had previously spent four years playing Division 1 college basketball for Quinnipiac University in the US. In 2017, she became the first Irish basketball player to reach the Sweet 16 round of the Division 1 NCAA tournament.</p>
<p>In an interview with <em>The University Times</em> last October, Thornton discussed her ambitions for the year. “I come from a winning background” she said, “and I don’t plan on changing that while I’m here”.</p>
<p>Thornton earns the award after finishing the season averaging 15.7 points per-game, along with six assists, six rebounds and 5.3 steals – the highest average in the league in this category.</p>
<p>This was O’Keefe&#8217;s second season with Trinity Meteors. He first took the job after the merger between Trinity basketball and Meteors last year, when Seamus Donnelly, a professor of medicine in Trinity, approached him.</p>
<p>The awards round off a hugely successful season for Meteors, who <a href="https://www.universitytimes.ie/2020/03/meteors-promoted-after-80-65-victory-over-st-marys-in-league-final/">secured promotion</a> to the Super League – the top tier of Irish club basketball – after defeating Team Tom McCarthy St Mary’s 80-65 in the Division 1 final last month.</p>
<p>Thornton and O’Keefe are due to receive their awards at a ceremony scheduled for next month in Croke Park. The event is subject to change, given the ongoing coronavirus pandemic.</p>
</p>
<div style="clear:both"> </div>
</section>
<div style="clear:both"> </div>




<div class="callededitorspicks">
<div class="editorspicks">
<h3 class="smallerbottommargin">Sign Up to Our Weekly Newsletters</h3>

<form action="//universitytimes.us2.list-manage.com/subscribe/post?u=c3156af84abbac47a9f091f17&amp;id=af56b178cc" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div class="getinyourinbox">Get The University Times into your inbox twice a week.</div>
<div class="zeroline">
<label for="mce-EMAIL" style="display: none;">Email Address </label>
<input type="email" style="margin-right: 0px;" value="Your email address" name="EMAIL" class="emailinput" id="mce-EMAIL" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;">
<input style="margin-left: 0px;" type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="emailsubscribe">
<div class="response" id="mce-error-response" style="display:none height: 0px; width: 0px;"></div>
<div class="response" id="mce-success-response" style="display:none height: 0px; width: 0px;"></div>

<div style="display: none; height: 0px; width: 0px;"><input type="text" name="b_c3156af84abbac47a9f091f17_af56b178cc" tabindex="-1" value=""></div>
</div>
</form>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
		jQuery('#mc-embedded-subscribe-form').validate();
		
		
		
		
		</script>

</div>
</div>
<div class="callededitorspicks">




<div class="editorspicks">
<h3>Editors' Picks</h3>
<a href="http://www.universitytimes.ie/2020/04/trinity-to-set-up-coronavirus-research-centre-with-e2-4m-aib-backing/" class="pickstory notopmargin">
<div class="pickcropper">
<img src="http://www.universitytimes.ie/wp-content/uploads/2018/04/34107571450_c257cae563_z.jpg" alt="blank" />
<script type="text/javascript">
											jQuery('.pickcropper').imagefill();
        						</script>
</div>
<h4>Trinity to Set Up Coronavirus Research Centre, With €2.4m AIB Backing</h4>
</a>
<a href="http://www.universitytimes.ie/2020/04/likelihood-grows-of-delay-to-leaving-certificate-exams/" class="pickstorymiddle">
<div class="pickcropper">
<img src="http://www.universitytimes.ie/wp-content/uploads/2014/05/arts_exams-e1399549755271.jpg" alt="blank" />
<script type="text/javascript">
											jQuery('.pickcropper').imagefill();
        						</script>
</div>
<h4>Likelihood Grows of Delay to Leaving Certificate Exams</h4>
</a>
<a href="http://www.universitytimes.ie/2020/04/when-it-comes-to-climate-academics-say-we-really-are-what-we-eat/" class="pickstoryright">
<div class="pickcropper">
<img src="http://www.universitytimes.ie/wp-content/uploads/2020/04/blaise-apple.png" alt="blank" />
<script type="text/javascript">
											jQuery('.pickcropper').imagefill();
        						</script>
</div>
<h4>When it Comes to Climate, Academics Say We Really Are What We Eat</h4>
</a>

<a href="http://www.universitytimes.ie/2020/04/college-has-said-no-to-no-detriment-but-obeyed-the-spirit-of-the-policy/" class="pickstory">
<div class="pickcropper">
<img src="http://www.universitytimes.ie/wp-content/uploads/2017/05/26687519306_faaa808556_z-1.jpg" alt="blank" />
<script type="text/javascript">
											jQuery('.pickcropper').imagefill();
        						</script>
</div>
<h4>College Has Said No to No Detriment – But Obeyed the Spirit of the Policy</h4>
</a>
<a href="http://www.universitytimes.ie/2020/04/ni-bheadh-polasai-gan-diobhail-foirfe-ach-is-e-an-moladh-is-fearr-ata-cloistithe-againn/" class="pickstorymiddle">
<div class="pickcropper">
<img src="http://www.universitytimes.ie/wp-content/uploads/2019/05/exams-in-progress.jpg" alt="blank" />
<script type="text/javascript">
											jQuery('.pickcropper').imagefill();
        						</script>
</div>
<h4>Ní Bheadh Polasaí Gan Díobháil Foirfe – Ach Is É An Moladh Is Fearr Atá Cloistithe Againn</h4>
</a>
<a href="http://www.universitytimes.ie/2020/04/trinity-to-reject-unworkable-no-detriment-but-offer-backup-options/" class="pickstoryright">
<div class="pickcropper">
<img src="http://www.universitytimes.ie/wp-content/uploads/2019/05/exams-in-progress.jpg" alt="blank" />
<script type="text/javascript">
											jQuery('.pickcropper').imagefill();
        						</script>
</div>
<h4>Trinity to Reject ‘Unworkable’ No Detriment, But Offer Backup Options</h4>
</a>
</div>
</div>
</div>
<div style="clear:both"> </div>
<div class="commentblock">
<div style="clear:both"> </div>
</div>
</div>
</div>
<script type='text/javascript' src='http://www.universitytimes.ie/wp-content/themes/universitytimes/library/js/scripts.js'></script>
<script type='text/javascript' src='http://www.universitytimes.ie/wp-includes/js/wp-embed.js'></script>
<div id="utfooter">
<a href="http://www.universitytimes.ie" class="utfooterlogo">
The University Times
</a>
<ul class="footermenu">
<li><a href="http://www.universitytimes.ie/about">About</a></li>
<li><a href="http://www.universitytimes.ie/masthead">Staff</a></li>
<li><a href="http://www.universitytimes.ie/editorialpolicy">Editorial and Ethics Policy</a></li>
<li><a href="http://www.universitytimes.ie/contribute">Contribute</a></li>
</ul>
<div style="clear: both"></div>
</div>
</body>
</html> 
